about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/uptime-kuma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/uptime-kuma.nix')
-rw-r--r--nixos/modules/services/monitoring/uptime-kuma.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/nixos/modules/services/monitoring/uptime-kuma.nix b/nixos/modules/services/monitoring/uptime-kuma.nix
index 7027046b2425..f3a41de7536a 100644
--- a/nixos/modules/services/monitoring/uptime-kuma.nix
+++ b/nixos/modules/services/monitoring/uptime-kuma.nix
@@ -13,12 +13,7 @@ in
     services.uptime-kuma = {
       enable = mkEnableOption (mdDoc "Uptime Kuma, this assumes a reverse proxy to be set");
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.uptime-kuma;
-        defaultText = literalExpression "pkgs.uptime-kuma";
-        description = lib.mdDoc "Uptime Kuma package to use.";
-      };
+      package = mkPackageOption pkgs "uptime-kuma" { };
 
       appriseSupport = mkEnableOption (mdDoc "apprise support for notifications");