about summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/bosun.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/bosun.nix')
-rw-r--r--nixos/modules/services/monitoring/bosun.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/monitoring/bosun.nix b/nixos/modules/services/monitoring/bosun.nix
index 1dc19743461b..fb412d43ec27 100644
--- a/nixos/modules/services/monitoring/bosun.nix
+++ b/nixos/modules/services/monitoring/bosun.nix
@@ -24,14 +24,7 @@ in {
 
       enable = mkEnableOption (lib.mdDoc "bosun");
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.bosun;
-        defaultText = literalExpression "pkgs.bosun";
-        description = lib.mdDoc ''
-          bosun binary to use.
-        '';
-      };
+      package = mkPackageOption pkgs "bosun" { };
 
       user = mkOption {
         type = types.str;