about summary refs log tree commit diff
path: root/nixos/modules/services/misc/guix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/guix/default.nix')
-rw-r--r--nixos/modules/services/misc/guix/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/guix/default.nix b/nixos/modules/services/misc/guix/default.nix
index 0524f0316e77..6c3874c0750a 100644
--- a/nixos/modules/services/misc/guix/default.nix
+++ b/nixos/modules/services/misc/guix/default.nix
@@ -274,7 +274,7 @@ in
         linkProfile = profile: location: let
           userProfile = guixProfile profile;
         in ''
-          [ -d "${userProfile}" ] && [ -L "${location}" ] || ln -sf "${userProfile}" "${location}"
+          [ -d "${userProfile}" ] && ln -sfn "${userProfile}" "${location}"
         '';
         linkProfileToPath = acc: profile: location: let
           in acc + (linkProfile profile location);