about summary refs log tree commit diff
path: root/nixos/modules/services/misc/gitweb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/gitweb.nix')
-rw-r--r--nixos/modules/services/misc/gitweb.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/services/misc/gitweb.nix b/nixos/modules/services/misc/gitweb.nix
index b0e34a690ca5..ca21366b7796 100644
--- a/nixos/modules/services/misc/gitweb.nix
+++ b/nixos/modules/services/misc/gitweb.nix
@@ -32,6 +32,14 @@ in
       '';
     };
 
+    gitwebTheme = mkOption {
+      default = false;
+      type = types.bool;
+      description = ''
+        Use an alternative theme for gitweb, strongly inspired by GitHub.
+      '';
+    };
+
     gitwebConfigFile = mkOption {
       default = pkgs.writeText "gitweb.conf" ''
         # path to git projects (<project>.git)