about summary refs log tree commit diff
path: root/nixos/modules/services/hardware/xow.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/hardware/xow.nix')
-rw-r--r--nixos/modules/services/hardware/xow.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/nixos/modules/services/hardware/xow.nix b/nixos/modules/services/hardware/xow.nix
new file mode 100644
index 000000000000..a97dd5c870d7
--- /dev/null
+++ b/nixos/modules/services/hardware/xow.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, lib, ... }:
+
+let
+  cfg = config.services.hardware.xow;
+in {
+  options.services.hardware.xow = {
+    enable = lib.mkEnableOption "Whether to enable xow or not.";
+  };
+
+  config = lib.mkIf cfg.enable {
+    hardware.uinput.enable = true;
+
+    users.users.xow = {
+      group = "uinput";
+      isSystemUser = true;
+    };
+
+    systemd.services.xow = {
+      wantedBy = [ "multi-user.target" ];
+      description = "Xbox One Wireless Dongle Driver";
+      after = [ "systemd-udev-settle.service" ];
+      serviceConfig = {
+        ExecStart = ''
+          ${pkgs.xow}/bin/xow
+        '';
+        User = "xow";
+      };
+    };
+  };
+}