about summary refs log tree commit diff
path: root/nixos/modules/services/hardware/joycond.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/hardware/joycond.nix')
-rw-r--r--nixos/modules/services/hardware/joycond.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/hardware/joycond.nix b/nixos/modules/services/hardware/joycond.nix
index df3239cb2a7d..060303b520e5 100644
--- a/nixos/modules/services/hardware/joycond.nix
+++ b/nixos/modules/services/hardware/joycond.nix
@@ -10,14 +10,7 @@ with lib;
   options.services.joycond = {
     enable = mkEnableOption (lib.mdDoc "support for Nintendo Pro Controllers and Joycons");
 
-    package = mkOption {
-      type = types.package;
-      default = pkgs.joycond;
-      defaultText = lib.literalExpression "pkgs.joycond";
-      description = lib.mdDoc ''
-        The joycond package to use.
-      '';
-    };
+    package = mkPackageOption pkgs "joycond" { };
   };
 
   config = mkIf cfg.enable {