about summary refs log tree commit diff
path: root/nixos/modules/services/games/minecraft-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/games/minecraft-server.nix')
-rw-r--r--nixos/modules/services/games/minecraft-server.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/games/minecraft-server.nix b/nixos/modules/services/games/minecraft-server.nix
index 7d26d1501650..39a68f4b5536 100644
--- a/nixos/modules/services/games/minecraft-server.nix
+++ b/nixos/modules/services/games/minecraft-server.nix
@@ -215,8 +215,8 @@ in {
     networking.firewall = mkIf cfg.openFirewall (if cfg.declarative then {
       allowedUDPPorts = [ serverPort ];
       allowedTCPPorts = [ serverPort ]
-        ++ optional (! isNull queryPort) queryPort
-        ++ optional (! isNull rconPort) rconPort;
+        ++ optional (queryPort != null) queryPort
+        ++ optional (rconPort != null) rconPort;
     } else {
       allowedUDPPorts = [ defaultServerPort ];
       allowedTCPPorts = [ defaultServerPort ];