about summary refs log tree commit diff
path: root/nixos/modules/services/desktops/accountsservice.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/desktops/accountsservice.nix')
-rw-r--r--nixos/modules/services/desktops/accountsservice.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/desktops/accountsservice.nix b/nixos/modules/services/desktops/accountsservice.nix
index 933b9da2c83c..c48036a99e8f 100644
--- a/nixos/modules/services/desktops/accountsservice.nix
+++ b/nixos/modules/services/desktops/accountsservice.nix
@@ -39,14 +39,14 @@ with lib;
 
     systemd.packages = [ pkgs.accountsservice ];
 
-    systemd.services.accounts-daemon = {
+    systemd.services.accounts-daemon = recursiveUpdate {
 
       wantedBy = [ "graphical.target" ];
 
       # Accounts daemon looks for dbus interfaces in $XDG_DATA_DIRS/accountsservice
       environment.XDG_DATA_DIRS = "${config.system.path}/share";
 
-    } // (optionalAttrs (!config.users.mutableUsers) {
+    } (optionalAttrs (!config.users.mutableUsers) {
       environment.NIXOS_USERS_PURE = "true";
     });
   };