about summary refs log tree commit diff
path: root/nixos/modules/services/databases/pgmanage.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/databases/pgmanage.nix')
-rw-r--r--nixos/modules/services/databases/pgmanage.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/databases/pgmanage.nix b/nixos/modules/services/databases/pgmanage.nix
index a0933a5ffc45..4b963aee4640 100644
--- a/nixos/modules/services/databases/pgmanage.nix
+++ b/nixos/modules/services/databases/pgmanage.nix
@@ -46,14 +46,7 @@ in {
   options.services.pgmanage = {
     enable = mkEnableOption (lib.mdDoc "PostgreSQL Administration for the web");
 
-    package = mkOption {
-      type = types.package;
-      default = pkgs.pgmanage;
-      defaultText = literalExpression "pkgs.pgmanage";
-      description = lib.mdDoc ''
-        The pgmanage package to use.
-      '';
-    };
+    package = mkPackageOption pkgs "pgmanage" { };
 
     connections = mkOption {
       type = types.attrsOf types.str;