about summary refs log tree commit diff
path: root/nixos/modules/services/databases/opentsdb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/databases/opentsdb.nix')
-rw-r--r--nixos/modules/services/databases/opentsdb.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/nixos/modules/services/databases/opentsdb.nix b/nixos/modules/services/databases/opentsdb.nix
index 288b716fce03..25f413db809f 100644
--- a/nixos/modules/services/databases/opentsdb.nix
+++ b/nixos/modules/services/databases/opentsdb.nix
@@ -17,14 +17,7 @@ in {
 
       enable = mkEnableOption (lib.mdDoc "OpenTSDB");
 
-      package = mkOption {
-        type = types.package;
-        default = pkgs.opentsdb;
-        defaultText = literalExpression "pkgs.opentsdb";
-        description = lib.mdDoc ''
-          OpenTSDB package to use.
-        '';
-      };
+      package = mkPackageOption pkgs "opentsdb" { };
 
       user = mkOption {
         type = types.str;