about summary refs log tree commit diff
path: root/nixos/modules/services/databases/influxdb.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/databases/influxdb.nix')
-rw-r--r--nixos/modules/services/databases/influxdb.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/nixos/modules/services/databases/influxdb.nix b/nixos/modules/services/databases/influxdb.nix
index b3361d2014ca..34b4139e7c58 100644
--- a/nixos/modules/services/databases/influxdb.nix
+++ b/nixos/modules/services/databases/influxdb.nix
@@ -116,12 +116,7 @@ in
         type = types.bool;
       };
 
-      package = mkOption {
-        default = pkgs.influxdb;
-        defaultText = literalExpression "pkgs.influxdb";
-        description = lib.mdDoc "Which influxdb derivation to use";
-        type = types.package;
-      };
+      package = mkPackageOption pkgs "influxdb" { };
 
       user = mkOption {
         default = "influxdb";