about summary refs log tree commit diff
path: root/nixos/modules/security/setuid-wrappers.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/security/setuid-wrappers.nix')
-rw-r--r--nixos/modules/security/setuid-wrappers.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/security/setuid-wrappers.nix b/nixos/modules/security/setuid-wrappers.nix
index 7d69f9b1183d..99dd514feea3 100644
--- a/nixos/modules/security/setuid-wrappers.nix
+++ b/nixos/modules/security/setuid-wrappers.nix
@@ -96,7 +96,7 @@ in
           }:
 
           ''
-            if ! source=${if source != "" then source else "$(PATH=$SETUID_PATH type -tP ${program})"}; then
+            if ! source=${if source != "" then source else "$(readlink -f $(PATH=$SETUID_PATH type -tP ${program}))"}; then
                 # If we can't find the program, fall back to the
                 # system profile.
                 source=/nix/var/nix/profiles/default/bin/${program}