about summary refs log tree commit diff
path: root/nixos/modules/programs/wireshark.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/programs/wireshark.nix')
-rw-r--r--nixos/modules/programs/wireshark.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/nixos/modules/programs/wireshark.nix b/nixos/modules/programs/wireshark.nix
index 834b0ba35695..c0dc349cca4a 100644
--- a/nixos/modules/programs/wireshark.nix
+++ b/nixos/modules/programs/wireshark.nix
@@ -16,13 +16,8 @@ in {
           setcap wrapper for 'dumpcap' for users in the 'wireshark' group.
         '';
       };
-      package = mkOption {
-        type = types.package;
-        default = pkgs.wireshark-cli;
-        defaultText = literalExpression "pkgs.wireshark-cli";
-        description = lib.mdDoc ''
-          Which Wireshark package to install in the global environment.
-        '';
+      package = mkPackageOption pkgs "wireshark-cli" {
+        example = "wireshark";
       };
     };
   };