about summary refs log tree commit diff
path: root/nixos/modules/programs/nylas-mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/programs/nylas-mail.nix')
-rw-r--r--nixos/modules/programs/nylas-mail.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/nixos/modules/programs/nylas-mail.nix b/nixos/modules/programs/nylas-mail.nix
new file mode 100644
index 000000000000..9a6cf755f2a2
--- /dev/null
+++ b/nixos/modules/programs/nylas-mail.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+  cfg = config.services.nylas-mail;
+  defaultUser = "nylas-mail";
+in {
+  ###### interface
+  options = {
+    services.nylas-mail = {
+
+      enable = mkEnableOption ''
+        nylas-mail - Open-source mail client built on the modern web with Electron, React, and Flux
+      '';
+
+      gnome3-keyring = mkOption {
+        type = types.bool;
+        default = true;
+        description = "Enable gnome3 keyring for nylas-mail.";
+      };
+    };
+  };
+
+
+  ###### implementation
+
+  config = mkIf cfg.enable {
+
+    environment.systemPackages = [ pkgs.nylas-mail-bin ];
+
+    services.gnome3.gnome-keyring = mkIf cfg.gnome3-keyring {
+      enable = true;
+    };
+
+  };
+}