about summary refs log tree commit diff
path: root/nixos/modules/misc/version.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/version.nix')
-rw-r--r--nixos/modules/misc/version.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/misc/version.nix b/nixos/modules/misc/version.nix
index 5ab24686152e..86898bbb3790 100644
--- a/nixos/modules/misc/version.nix
+++ b/nixos/modules/misc/version.nix
@@ -8,31 +8,31 @@ with pkgs.lib;
 
     system.nixosVersion = mkOption {
       internal = true;
-      type = types.uniq types.string;
+      type = types.str;
       description = "NixOS version.";
     };
 
     system.nixosVersionSuffix = mkOption {
       internal = true;
-      type = types.uniq types.string;
+      type = types.str;
       description = "NixOS version suffix.";
     };
 
     system.nixosRevision = mkOption {
       internal = true;
-      type = types.uniq types.string;
+      type = types.str;
       description = "NixOS Git revision hash.";
     };
 
     system.nixosCodeName = mkOption {
       internal = true;
-      type = types.uniq types.string;
+      type = types.str;
       description = "NixOS release code name.";
     };
 
     system.defaultChannel = mkOption {
       internal = true;
-      type = types.uniq types.string;
+      type = types.str;
       default = https://nixos.org/channels/nixos-unstable;
       description = "Default NixOS channel to which the root user is subscribed.";
     };