about summary refs log tree commit diff
path: root/nixos/modules/i18n/inputMethod/uim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/i18n/inputMethod/uim.nix')
-rw-r--r--nixos/modules/i18n/inputMethod/uim.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/nixos/modules/i18n/inputMethod/uim.nix b/nixos/modules/i18n/inputMethod/uim.nix
index 0154cdc5057a..401e1932f70c 100644
--- a/nixos/modules/i18n/inputMethod/uim.nix
+++ b/nixos/modules/i18n/inputMethod/uim.nix
@@ -9,15 +9,6 @@ in
   options = {
 
     i18n.inputMethod.uim = {
-      enable = mkOption {
-        type    = types.bool;
-        default = false;
-        example = true;
-        description = ''
-          Enable uim input method.
-          Uim can be used to input of Chinese, Korean, Japanese and other special characters.
-        '';
-      };
       toolbar = mkOption {
         type    = types.enum [ "gtk" "gtk3" "gtk-systray" "gtk3-systray" "qt4" ];
         default = "gtk";
@@ -30,7 +21,7 @@ in
 
   };
 
-  config = mkIf cfg.enable {
+  config = mkIf (config.i18n.inputMethod.enabled == "uim") {
     environment.systemPackages = [ pkgs.uim ];
     gtkPlugins = [ pkgs.uim ];
     qtPlugins  = [ pkgs.uim ];