about summary refs log tree commit diff
path: root/nixos/modules/i18n/inputMethod/nabi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/i18n/inputMethod/nabi.nix')
-rw-r--r--nixos/modules/i18n/inputMethod/nabi.nix22
1 files changed, 1 insertions, 21 deletions
diff --git a/nixos/modules/i18n/inputMethod/nabi.nix b/nixos/modules/i18n/inputMethod/nabi.nix
index 7f97135fee1e..8c3965955130 100644
--- a/nixos/modules/i18n/inputMethod/nabi.nix
+++ b/nixos/modules/i18n/inputMethod/nabi.nix
@@ -1,28 +1,8 @@
 { config, pkgs, lib, ... }:
 
 with lib;
-
-let 
-  cfg = config.i18n.inputMethod.nabi;
-in
-{
-  options = {
-
-    i18n.inputMethod.nabi = {
-      enable = mkOption {
-        type    = types.bool;
-        default = false;
-        example = true;
-        description = ''
-          Enable nabi input method.
-          Nabi can be used to input Korean.
-        '';
-      };
-    };
-
-  };
 {
-  config = mkIf cfg.enable {
+  config = mkIf (config.i18n.inputMethod.enabled == "nabi") {
     environment.systemPackages = [ pkgs.nabi ];
     qtPlugins  = [ pkgs.nabi ];