about summary refs log tree commit diff
path: root/nixos/modules/i18n/inputMethod/ibus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/i18n/inputMethod/ibus.nix')
-rw-r--r--nixos/modules/i18n/inputMethod/ibus.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/nixos/modules/i18n/inputMethod/ibus.nix b/nixos/modules/i18n/inputMethod/ibus.nix
index e4bc15cf8912..86059751a3d2 100644
--- a/nixos/modules/i18n/inputMethod/ibus.nix
+++ b/nixos/modules/i18n/inputMethod/ibus.nix
@@ -13,15 +13,6 @@ in
 {
   options = {
     i18n.inputMethod.ibus = {
-      enable = mkOption {
-        type    = types.bool;
-        default = false;
-        example = true;
-        description = ''
-          Enable IBus input method.
-          IBus can be used input of Chinese, Korean, Japanese and other special characters.
-        '';
-      };
       engines = mkOption {
         type    = with types; listOf ibusEngine;
         default = [];
@@ -34,7 +25,7 @@ in
     };
   };
 
-  config = mkIf cfg.enable {
+  config = mkIf (config.i18n.inputMethod.enabled == "ibus") {
     # Without dconf enabled it is impossible to use IBus
     environment.systemPackages = [ ibusPackage pkgs.gnome3.dconf ];