about summary refs log tree commit diff
path: root/nixos/modules/i18n/inputMethod/fcitx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/i18n/inputMethod/fcitx.nix')
-rw-r--r--nixos/modules/i18n/inputMethod/fcitx.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/nixos/modules/i18n/inputMethod/fcitx.nix b/nixos/modules/i18n/inputMethod/fcitx.nix
index b0e7578810ad..f168f4451703 100644
--- a/nixos/modules/i18n/inputMethod/fcitx.nix
+++ b/nixos/modules/i18n/inputMethod/fcitx.nix
@@ -14,15 +14,6 @@ in
   options = {
 
     i18n.inputMethod.fcitx = {
-      enable = mkOption {
-        type    = types.bool;
-        default = false;
-        example = true;
-        description = ''
-          Enable Fcitx input method.
-          Fcitx can be used to input of Chinese, Korean, Japanese and other special characters.
-        '';
-      };
       engines = mkOption {
         type    = with types; listOf fcitxEngine;
         default = [];
@@ -36,7 +27,7 @@ in
 
   };
 
-  config = mkIf cfg.enable {
+  config = mkIf (config.i18n.inputMethod.enabled == "fcitx") {
     environment.systemPackages = [ fcitxPackage ];
     gtkPlugins = [ fcitxPackage ];
     qtPlugins  = [ fcitxPackage ];