about summary refs log tree commit diff
path: root/nixos/modules/hardware/steam-hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/hardware/steam-hardware.nix')
-rw-r--r--nixos/modules/hardware/steam-hardware.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/nixos/modules/hardware/steam-hardware.nix b/nixos/modules/hardware/steam-hardware.nix
index 378aeffe71b5..6218c9ffbb9b 100644
--- a/nixos/modules/hardware/steam-hardware.nix
+++ b/nixos/modules/hardware/steam-hardware.nix
@@ -21,5 +21,12 @@ in
     services.udev.packages = [
       pkgs.steamPackages.steam
     ];
+
+    # The uinput module needs to be loaded in order to trigger the udev rules
+    # defined in the steam package for setting permissions on /dev/uinput.
+    #
+    # If the udev rules are not triggered, some controllers won't work with
+    # steam.
+    boot.kernelModules = [ "uinput" ];
   };
 }