about summary refs log tree commit diff
path: root/nixos/modules/hardware/opengl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/hardware/opengl.nix')
-rw-r--r--nixos/modules/hardware/opengl.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/nixos/modules/hardware/opengl.nix b/nixos/modules/hardware/opengl.nix
index c2c36f02a143..d9646704e6f6 100644
--- a/nixos/modules/hardware/opengl.nix
+++ b/nixos/modules/hardware/opengl.nix
@@ -34,10 +34,17 @@ in
 {
   options = {
     hardware.opengl.enable = mkOption {
-      description = "Whether this configuration requires OpenGL.";
+      description = ''
+        Whether to enable OpenGL drivers. This is needed to enable
+        OpenGL support in X11 systems, as well as for Wayland compositors
+        like sway, way-cooler and Weston. It is enabled by default
+        by the corresponding modules, so you do not usually have to
+        set it yourself, only if there is no module for your wayland
+        compositor of choice. See services.xserver.enable,
+        programs.sway.enable, and programs.way-cooler.enable.
+      '';
       type = types.bool;
       default = false;
-      internal = true;
     };
 
     hardware.opengl.driSupport = mkOption {