about summary refs log tree commit diff
path: root/nixos/modules/hardware/all-firmware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/hardware/all-firmware.nix')
-rw-r--r--nixos/modules/hardware/all-firmware.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nixos/modules/hardware/all-firmware.nix b/nixos/modules/hardware/all-firmware.nix
index d0d481f72a40..fb8e1ccab667 100644
--- a/nixos/modules/hardware/all-firmware.nix
+++ b/nixos/modules/hardware/all-firmware.nix
@@ -22,7 +22,11 @@ with lib;
   ###### implementation
 
   config = mkIf config.hardware.enableAllFirmware {
-    hardware.firmware = [ pkgs.firmwareLinuxNonfree pkgs.intel2200BGFirmware ];
+    hardware.firmware = with pkgs; [
+      firmwareLinuxNonfree
+      intel2200BGFirmware
+      rtl8723bs-firmware
+    ];
   };
 
 }