about summary refs log tree commit diff
path: root/nixos/modules/config/system-environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/config/system-environment.nix')
-rw-r--r--nixos/modules/config/system-environment.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/config/system-environment.nix b/nixos/modules/config/system-environment.nix
index b30c4e064750..3ab32f00fd1d 100644
--- a/nixos/modules/config/system-environment.nix
+++ b/nixos/modules/config/system-environment.nix
@@ -14,7 +14,7 @@ in
 
   options = {
 
-    environment.systemVariables = mkOption {
+    environment.sessionVariables = mkOption {
       default = {};
       description = ''
         A set of environment variables used in the global environment.
@@ -48,7 +48,7 @@ in
        ''
          ${concatStringsSep "\n" (
            (mapAttrsToList (n: v: ''${n}="${concatStringsSep ":" v}"'')
-             (zipAttrsWith (const concatLists) ([ (mapAttrs (n: v: [ v ]) cfg.systemVariables) ]))))}
+             (zipAttrsWith (const concatLists) ([ (mapAttrs (n: v: [ v ]) cfg.sessionVariables) ]))))}
        '';
 
   };