about summary refs log tree commit diff
path: root/nixos/modules/config/system-environment.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-06-13 17:56:46 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-06-13 17:57:04 +0200
commitf5055e2ef6cbb7e836ba80d8458647555aae6793 (patch)
tree83780de826479d1df5b862f9b0bb867148542602 /nixos/modules/config/system-environment.nix
parent27c72f337b2d5e247a513a553473b00f93eb7871 (diff)
downloadnixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar.gz
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar.bz2
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar.lz
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar.xz
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.tar.zst
nixlib-f5055e2ef6cbb7e836ba80d8458647555aae6793.zip
Rename environment.systemVariables -> environment.sessionVariables
This makes it clearer that they're part of PAM sessions.
Diffstat (limited to 'nixos/modules/config/system-environment.nix')
-rw-r--r--nixos/modules/config/system-environment.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/config/system-environment.nix b/nixos/modules/config/system-environment.nix
index b30c4e064750..3ab32f00fd1d 100644
--- a/nixos/modules/config/system-environment.nix
+++ b/nixos/modules/config/system-environment.nix
@@ -14,7 +14,7 @@ in
 
   options = {
 
-    environment.systemVariables = mkOption {
+    environment.sessionVariables = mkOption {
       default = {};
       description = ''
         A set of environment variables used in the global environment.
@@ -48,7 +48,7 @@ in
        ''
          ${concatStringsSep "\n" (
            (mapAttrsToList (n: v: ''${n}="${concatStringsSep ":" v}"'')
-             (zipAttrsWith (const concatLists) ([ (mapAttrs (n: v: [ v ]) cfg.systemVariables) ]))))}
+             (zipAttrsWith (const concatLists) ([ (mapAttrs (n: v: [ v ]) cfg.sessionVariables) ]))))}
        '';
 
   };