about summary refs log tree commit diff
path: root/nixos/modules/config/swap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/config/swap.nix')
-rw-r--r--nixos/modules/config/swap.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/config/swap.nix b/nixos/modules/config/swap.nix
index fb171050d3e8..65d7722abfa7 100644
--- a/nixos/modules/config/swap.nix
+++ b/nixos/modules/config/swap.nix
@@ -34,13 +34,13 @@ with utils;
 
           device = mkOption {
             example = "/dev/sda3";
-            type = types.uniq types.string;
+            type = types.str;
             description = "Path of the device.";
           };
 
           label = mkOption {
             example = "swap";
-            type = types.uniq types.string;
+            type = types.str;
             description = ''
               Label of the device.  Can be used instead of <varname>device</varname>.
             '';