about summary refs log tree commit diff
path: root/modules/workstation/hardware/keyboard/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/workstation/hardware/keyboard/default.nix')
-rw-r--r--modules/workstation/hardware/keyboard/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/workstation/hardware/keyboard/default.nix b/modules/workstation/hardware/keyboard/default.nix
new file mode 100644
index 000000000000..d2b13640277c
--- /dev/null
+++ b/modules/workstation/hardware/keyboard/default.nix
@@ -0,0 +1,22 @@
+{ pkgs, config, ... }:
+
+let
+  xcfg = config.services.xserver;
+
+in
+{
+  i18n.consoleUseXkbConfig = true;
+  services.xserver.layout = "dvorak";
+  services.xserver.xkbOptions = "ctrl:nocaps,compose:menu";
+
+  environment.variables.XKB_DEFAULT_LAYOUT = xcfg.layout;
+  environment.variables.XKB_DEFAULT_OPTIONS = xcfg.xkbOptions;
+
+  services.evscript.enable = true;
+  services.evscript.script = ./events.dyon;
+
+  boot.postBootCommands = ''
+    # Remap tab to left super
+    /run/current-system/sw/bin/setkeycodes 0f 125
+  '';
+}