about summary refs log tree commit diff
path: root/modules/shell/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/shell/git/default.nix')
-rw-r--r--modules/shell/git/default.nix8
1 files changed, 0 insertions, 8 deletions
diff --git a/modules/shell/git/default.nix b/modules/shell/git/default.nix
index cbc86957f9ff..9b1d6efa8235 100644
--- a/modules/shell/git/default.nix
+++ b/modules/shell/git/default.nix
@@ -9,19 +9,11 @@ let
     python = pkgs.python3;
   };
 
-  # Git only supports absolute paths for this, so give it a wrapper
-  # program that execs the msmtp in PATH.
-  sendmail = pkgs.writeScript "git-sendmail" ''
-    #! ${pkgs.execline}/bin/execlineb -S0
-    msmtp $@
-  '';
-
   config = pkgs.substituteAll {
     src = ./config.in;
 
     inherit mozlz4_textconv;
     python = pkgs.python3;
-    smtpServer = sendmail;
     attributesfile = ./attributes;
     ignorefile = ./ignore;
     preferLocalBuild = true;