about summary refs log tree commit diff
path: root/modules/shell/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/shell/default.nix')
-rw-r--r--modules/shell/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/modules/shell/default.nix b/modules/shell/default.nix
new file mode 100644
index 000000000000..cbf3a79f73e7
--- /dev/null
+++ b/modules/shell/default.nix
@@ -0,0 +1,45 @@
+{ pkgs, config, ... }:
+
+{
+  environment.systemPackages = with pkgs.pkgsConfigured; [
+    coreutils-prefixed
+    curl
+    fzf
+    gitSVN
+    gnused
+    gotop
+    httpie
+    jq
+    kakoune
+    less
+    lynx
+    moreutils
+    ncdu
+    neovim
+    nmap
+    openssh
+    pass
+    pv
+    ranger
+    silver-searcher
+    tmux
+    tree
+    units
+    unixtools.watch
+    wget
+    whois
+  ] ++ lib.optional stdenv.isDarwin pinentry_mac;
+
+  environment.shells = with pkgs.pkgsConfigured; [ zsh ];
+
+  environment.variables.EDITOR = "kak";
+  environment.variables.EMAIL = "hi@alyssa.is";
+
+  environment.etc.zshrc.text = ''
+    unsetopt GLOBAL_RCS
+
+    if [ -z "$__NIXOS_SET_ENVIRONMENT_DONE" ]; then
+        . ${config.system.build.setEnvironment}
+    fi
+  '';
+}