about summary refs log tree commit diff
path: root/modules/server/spectrum/cgit/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/server/spectrum/cgit/default.nix')
-rw-r--r--modules/server/spectrum/cgit/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/modules/server/spectrum/cgit/default.nix b/modules/server/spectrum/cgit/default.nix
index 7d7573c3e1cd..f6df47872789 100644
--- a/modules/server/spectrum/cgit/default.nix
+++ b/modules/server/spectrum/cgit/default.nix
@@ -23,7 +23,7 @@ let
   } ''
     mkdir -p $out/bin
     sed s/pastie/friendly/g >$out/bin/syntax-highlighting.py \
-       <${pkgs.cgit}/lib/cgit/filters/.syntax-highlighting.py-wrapped
+       <${pkgs.cgit-pink}/lib/cgit/filters/.syntax-highlighting.py-wrapped
     chmod +x $out/bin/syntax-highlighting.py
     wrapPythonPrograms
   '';
@@ -33,6 +33,7 @@ in
   imports = [ ../../cgit ];
 
   services.cgit.instances.spectrum = {
+    package = pkgs.cgit-pink;
     vhost = "spectrum-os.org";
     path = "/git";
     config = pkgs.writeText "cgit.conf" ''
@@ -51,7 +52,7 @@ in
       root-readme=${spectrumReadme}
       root-title=Spectrum Git Repository Browser
       snapshots=all
-      about-filter=${pkgs.cgit}/lib/cgit/filters/about-formatting.sh
+      about-filter=${pkgs.cgit-pink}/lib/cgit/filters/about-formatting.sh
       source-filter=${sourceFilter}/bin/syntax-highlighting.py
 
       scan-path=/home/spectrum/git