about summary refs log tree commit diff
path: root/modules/persistence/bluetooth/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/persistence/bluetooth/default.nix')
-rw-r--r--modules/persistence/bluetooth/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/persistence/bluetooth/default.nix b/modules/persistence/bluetooth/default.nix
new file mode 100644
index 000000000000..0f3bc0852341
--- /dev/null
+++ b/modules/persistence/bluetooth/default.nix
@@ -0,0 +1,10 @@
+{ config, lib, ... }:
+
+{
+  config = lib.mkIf config.hardware.bluetooth.enable {
+    systemd.tmpfiles.rules = [
+      "d /persist/safe/var/lib/bluetooth 0700"
+      "L+ /var/lib/bluetooth - - - - /persist/safe/var/lib/bluetooth"
+    ];
+  };
+}