about summary refs log tree commit diff
path: root/modules/nixos-hardware/apple/macbook-air/3/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/apple/macbook-air/3/default.nix')
-rw-r--r--modules/nixos-hardware/apple/macbook-air/3/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/nixos-hardware/apple/macbook-air/3/default.nix b/modules/nixos-hardware/apple/macbook-air/3/default.nix
new file mode 100644
index 000000000000..03221edcd0b0
--- /dev/null
+++ b/modules/nixos-hardware/apple/macbook-air/3/default.nix
@@ -0,0 +1,15 @@
+{ config, lib, ... }:
+
+{
+  imports = [ 
+    ../../.
+    ../../../common/pc/laptop
+    ../../../common/pc/ssd
+  ];
+
+  # Built-in iSight is recognized by the generic uvcvideo kernel module
+  hardware.facetimehd.enable = false;
+
+  hardware.cpu.intel.updateMicrocode =
+    lib.mkDefault config.hardware.enableRedistributableFirmware;
+}