about summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/types.nix b/lib/types.nix
index f459cda73cb5..07a6cc69fdca 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -182,11 +182,11 @@ rec {
           let
             coerce = def: if builtins.isFunction def then def else { config = def; };
             modules = opts' ++ map coerce defs;
-          in (evalModules' args.prefix modules args).config;
-        getSubOptions = prefix: (evalModules' prefix opts'
-          # FIXME: hack to get shit to evaluate.
-          { name = ""; }
-        ).options;
+          in (evalModules { inherit modules args; prefix = args.prefix; }).config;
+        getSubOptions = prefix: (evalModules
+          { modules = opts'; inherit prefix;
+            # FIXME: hack to get shit to evaluate.
+            args = { name = ""; }; }).options;
       };
 
     # Obsolete alternative to configOf.  It takes its option