about summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 77105740bc23..e9e45dc25c72 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -499,6 +499,7 @@ rec {
         show = v:
                if builtins.isString v then ''"${v}"''
           else if builtins.isInt v then builtins.toString v
+          else if builtins.isBool v then if v then "true" else "false"
           else ''<${builtins.typeOf v}>'';
       in
       mkOptionType rec {