about summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 34d06a9144fe..8deb379c25a9 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -54,6 +54,14 @@ rec {
       check = builtins.isInt;
     };
 
+    str = mkOptionType {
+      name = "string";
+      check = builtins.isString;
+      merge = mergeOneOption;
+    };
+
+    # Deprecated; should not be used because it quietly concatenates
+    # strings, which is usually not what you want.
     string = mkOptionType {
       name = "string";
       check = builtins.isString;