about summary refs log tree commit diff
path: root/lib/modules.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/modules.nix')
-rw-r--r--lib/modules.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/lib/modules.nix b/lib/modules.nix
index c6d178e7ff9a..5e7f5d7a86d4 100644
--- a/lib/modules.nix
+++ b/lib/modules.nix
@@ -220,16 +220,6 @@ let
               within a configuration, but can be used in module imports.
             '';
           };
-
-          _module.class = mkOption {
-            readOnly = true;
-            internal = true;
-            description = lib.mdDoc ''
-              If the `class` attribute is set and non-`null`, the module system will reject `imports` with a different `class`.
-
-              This option contains the expected `class` attribute of the current module evaluation.
-            '';
-          };
         };
 
         config = {
@@ -237,7 +227,6 @@ let
             inherit extendModules;
             moduleType = type;
           };
-          _module.class = class;
           _module.specialArgs = specialArgs;
         };
       };
@@ -337,6 +326,7 @@ let
         config = checked (removeAttrs config [ "_module" ]);
         _module = checked (config._module);
         inherit extendModules type;
+        configurationClass = class;
       };
     in result;