about summary refs log tree commit diff
path: root/config/weechat/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/weechat/module.nix')
-rw-r--r--config/weechat/module.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/config/weechat/module.nix b/config/weechat/module.nix
new file mode 100644
index 000000000000..439fe175ae83
--- /dev/null
+++ b/config/weechat/module.nix
@@ -0,0 +1,12 @@
+{ pkgs, ... }:
+
+{
+  home.qyliss.dirs."state/weechat".activationScripts.git = ''
+    ${pkgs.git}/bin/git init -q
+    ${pkgs.git}/bin/git remote rm origin 2>/dev/null || true
+    ${pkgs.git}/bin/git remote add origin git@github.com:alyssais/weechat-config
+    chown -R qyliss .git
+  '';
+
+  environment.systemPackages = with pkgs.pkgsConfigured; [ weechat ];
+}