about summary refs log tree commit diff
path: root/common/pc/laptop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/pc/laptop/default.nix')
-rw-r--r--common/pc/laptop/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/common/pc/laptop/default.nix b/common/pc/laptop/default.nix
index 305c160e2094..5da1e60a449f 100644
--- a/common/pc/laptop/default.nix
+++ b/common/pc/laptop/default.nix
@@ -7,5 +7,10 @@
     "vm.laptop_mode" = lib.mkDefault 5;
   };
 
+  # TODO: fix in NixOS/nixpkgs
+  # Disable governor set in hardware-configuration.nix,
+  # required when services.tlp.enable is true:
+  powerManagement.cpuFreqGovernor = lib.mkForce null;
+
   services.tlp.enable = lib.mkDefault true;
 }