about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichiel Leenaars <ml.software@leenaa.rs>2016-06-03 20:00:07 +0200
committerMichiel Leenaars <ml.software@leenaa.rs>2016-08-08 15:14:22 +0200
commitfc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1 (patch)
treeb8d6e51d868a7432d7cde87a578b81921c804ba0 /pkgs/top-level
parent93a9643aeddcb28f7535d05826088553d9b7a49d (diff)
downloadnixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar.gz
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar.bz2
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar.lz
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar.xz
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.tar.zst
nixlib-fc71e1e178347cb1cacfa31d7e1f9ed37dac2fd1.zip
pythonpackages.attrs: init -> 16.0.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index ff6ee1e401dd..429dbe1606ef 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -1208,6 +1208,27 @@ in modules // {
     };
   });
 
+  attrs = buildPythonPackage (rec {
+    pname = "attrs";
+    version = "16.0.0";
+    name = "attrs-16.0.0";
+    src = pkgs.fetchurl {
+      url = "mirror://pypi/a/attrs/${name}.tar.gz";
+      sha256 = "1g4asv3hbx5aqz7hjzq3q6ss2cpv1rdv66sp5d21cdyjajj2fs6y";
+    };
+
+    # Mac OS X needs clang for testing
+    buildInputs = with self; [ pytest hypothesis zope_interface
+    pympler coverage ]
+     ++ optionals (stdenv.isDarwin) [ pkgs.clang ];
+
+    meta = {
+      description = "Python attributes without boilerplate";
+      homepage = https://github.com/hynek/attrs;
+      license = licenses.mit;
+    };
+   });
+
   audioread = buildPythonPackage rec {
     name = "audioread-${version}";
     version = "2.1.1";