about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-05-25 20:38:18 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-05-25 20:38:18 +0000
commitfa1a414aeea9926721ed2b87b74e3f3755538e3b (patch)
tree5e4d6aea8bcd00c53b71a564ce9e0fe001751a84 /pkgs/top-level
parentd15811bf78eda2aacfa5274822ba07a911d9bca6 (diff)
parentc5098ff56e44ab8eeae3a067838cf4e139196d52 (diff)
downloadnixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar.gz
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar.bz2
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar.lz
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar.xz
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.tar.zst
nixlib-fa1a414aeea9926721ed2b87b74e3f3755538e3b.zip
Merging from trunk - I had to resolve conflicts on coreutils; I hope I resolved that
well


svn path=/nixpkgs/branches/stdenv-updates/; revision=21975
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix135
-rw-r--r--pkgs/top-level/perl-packages.nix4
-rw-r--r--pkgs/top-level/python-packages.nix6
-rw-r--r--pkgs/top-level/release-cross.nix10
-rw-r--r--pkgs/top-level/release-lib.nix23
-rw-r--r--pkgs/top-level/release.nix2
6 files changed, 145 insertions, 35 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 8afede97c855..c50acf1ef8c7 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -371,6 +371,10 @@ let
   aria = builderDefsPackage (import ../tools/networking/aria) {
   };
 
+  aria2 = import ../tools/networking/aria2 {
+    inherit fetchurl stdenv openssl libxml2 zlib;
+  };
+
   at = import ../tools/system/at {
     inherit fetchurl stdenv bison flex pam ssmtp;
   };
@@ -542,7 +546,9 @@ let
       else import ../tools/misc/coreutils)
     {
       inherit fetchurl stdenv acl perl gmp;
-      aclSupport = stdenv.isLinux;
+
+      # TODO: Add ACL support for cross-Linux.
+      aclSupport = (crossSystem == null) && stdenv.isLinux;
     };
 
   coreutils = useFromStdenv "coreutils" coreutils_real;
@@ -628,6 +634,10 @@ let
       inherit fetchurl stdenv coreutils;
     });
 
+  dirmngr = import ../tools/security/dirmngr {
+    inherit stdenv fetchurl libgpgerror libgcrypt libassuan libksba openldap;
+  };
+
   docbook2x = import ../tools/typesetting/docbook2x {
     inherit fetchurl stdenv texinfo perl
             gnused groff libxml2 libxslt makeWrapper;
@@ -646,8 +656,9 @@ let
   };
 
   duplicity = import ../tools/backup/duplicity {
-    inherit fetchurl stdenv librsync gnupg makeWrapper python;
+    inherit fetchurl stdenv librsync makeWrapper python;
     inherit (pythonPackages) boto;
+    gnupg = gnupg1;
   };
 
   dvdplusrwtools = import ../tools/cd-dvd/dvd+rw-tools {
@@ -807,14 +818,21 @@ let
     inherit fetchurl stdenv ed;
   });
 
-  gnupg = makeOverridable (import ../tools/security/gnupg) {
+  gnupg1orig = makeOverridable (import ../tools/security/gnupg1) {
     inherit fetchurl stdenv readline bzip2;
     ideaSupport = false;
   };
 
-  gnupg2 = makeOverridable (import ../tools/security/gnupg2) {
+  gnupg1compat = import ../tools/security/gnupg1compat {
+    inherit stdenv gnupg writeScript coreutils;
+  };
+
+  # use config.packageOverrides if you prefer original gnupg1
+  gnupg1 = gnupg1compat;
+
+  gnupg = makeOverridable (import ../tools/security/gnupg) {
     inherit fetchurl stdenv readline libgpgerror libgcrypt libassuan pth libksba zlib
-      openldap bzip2 libusb curl;
+      openldap bzip2 libusb curl coreutils;
   };
 
   gnuplot = makeOverridable (import ../tools/graphics/gnuplot) {
@@ -1078,6 +1096,10 @@ let
     flex = flex2535;
   };
 
+  miniupnpd = import ../tools/networking/miniupnpd {
+    inherit fetchurl stdenv iptables;
+  };
+
   mjpegtools = import ../tools/video/mjpegtools {
     inherit fetchurl stdenv libjpeg;
     inherit (xlibs) libX11;
@@ -1271,7 +1293,7 @@ let
 
   opensc_0_11_7 = import ../tools/security/opensc/0.11.7.nix {
     inherit fetchurl stdenv libtool readline zlib openssl libiconv pcsclite
-      libassuan pkgconfig pinentry;
+      libassuan1 pkgconfig pinentry;
     inherit (xlibs) libXt;
   };
 
@@ -1369,8 +1391,8 @@ let
     inherit (xlibs) libX11;
   };
 
-  pinentry = import ../tools/misc/pinentry {
-    inherit fetchurl stdenv pkgconfig ncurses;
+  pinentry = makeOverridable (import ../tools/misc/pinentry) {
+    inherit fetchurl stdenv pkgconfig ncurses qt4;
     inherit (gnome) glib gtk;
   };
 
@@ -2091,7 +2113,13 @@ let
   };
 
   gccCrossStageFinal = wrapGCCCross {
-    gcc = forceBuildDrv gcc_realCross;
+    gcc = forceBuildDrv (gcc_realCross.override {
+      libpthreadCross =
+        # FIXME: Don't explicitly refer to `i586-pc-gnu'.
+        if crossSystem != null && crossSystem.config == "i586-pc-gnu"
+        then hurdLibpthreadCross
+        else null;
+     });
     libc = libcCross;
     binutils = binutilsCross;
     cross = assert crossSystem != null; crossSystem;
@@ -2110,7 +2138,7 @@ let
   }));
 
   gcc45 = lowPrio (wrapGCC (makeOverridable (import ../development/compilers/gcc-4.5) {
-    inherit fetchurl stdenv texinfo gmp mpfr mpc libelf zlib
+    inherit fetchurl stdenv texinfo gmp mpfr mpc libelf zlib perl
       ppl cloogppl
       gettext which noSysDirs;
     profiledCompiler = true;
@@ -2190,7 +2218,7 @@ let
     langCC = true;
     langC = false;
     profiledCompiler = false;
-    inherit zip unzip zlib boehmgc gettext pkgconfig;
+    inherit zip unzip zlib boehmgc gettext pkgconfig perl;
     inherit (gtkLibs) gtk;
     inherit (gnome) libart_lgpl;
     inherit (xlibs) libX11 libXt libSM libICE libXtst libXi libXrender
@@ -3244,10 +3272,9 @@ let
     inherit fetchurl stdenv builderDefs stringsWithDeps lib elfutils;
   };
 
-  migCross = forceBuildDrv (import ../development/tools/misc/mig {
+  mig = import ../os-specific/gnu/mig {
     inherit fetchgit stdenv autoconf automake flex bison machHeaders;
-    cross = assert crossSystem != null; crossSystem;
-  });
+  };
 
   mk = import ../development/tools/build-managers/mk {
     inherit fetchurl stdenv;
@@ -3711,7 +3738,8 @@ let
   };
 
   ffmpeg = import ../development/libraries/ffmpeg {
-    inherit fetchurl stdenv faad2 libvorbis speex libtheora x264 pkgconfig xvidcore;
+    inherit fetchurl stdenv faad2 libvorbis speex libtheora x264 pkgconfig xvidcore
+      lame yasm;
   };
 
   fftw = import ../development/libraries/fftw {
@@ -3901,10 +3929,7 @@ let
      //
 
      (if crossGNU
-      then {
-        inherit machHeaders hurdHeaders fetchgit;
-        mig = migCross;
-      }
+      then { inherit machHeaders hurdHeaders mig fetchgit; }
       else { }))));
 
   glibcCross = glibc211Cross;
@@ -4030,7 +4055,7 @@ let
   };
 
   gpgme = import ../development/libraries/gpgme {
-    inherit fetchurl stdenv libgpgerror pkgconfig pth gnupg gnupg2 glib;
+    inherit fetchurl stdenv libgpgerror pkgconfig pth gnupg glib libassuan;
   };
 
   gsasl = import ../development/libraries/gsasl {
@@ -4046,7 +4071,7 @@ let
   };
 
   gss = import ../development/libraries/gss {
-    inherit stdenv fetchurl;
+    inherit stdenv fetchurl shishi;
   };
 
   gtkimageview = import ../development/libraries/gtkimageview {
@@ -4181,8 +4206,7 @@ let
   };
 
   hwloc = import ../development/libraries/hwloc {
-    inherit fetchurl stdenv pkgconfig cairo expat ncurses
-      autoconf automake libtool;
+    inherit fetchurl stdenv pkgconfig cairo expat ncurses;
   };
 
   hydraAntLogger = import ../development/libraries/java/hydra-ant-logger {
@@ -4300,10 +4324,14 @@ let
       openssl attr;
   };
 
-  libassuan = import ../development/libraries/libassuan {
+  libassuan1 = import ../development/libraries/libassuan1 {
     inherit fetchurl stdenv pth;
   };
 
+  libassuan = import ../development/libraries/libassuan {
+    inherit fetchurl stdenv pth libgpgerror;
+  };
+
   libavc1394 = import ../development/libraries/libavc1394 {
     inherit fetchurl stdenv pkgconfig libraw1394;
   };
@@ -4713,6 +4741,10 @@ let
     inherit fetchurl stdenv pkgconfig ncurses gpm glib;
   };
 
+  libvpx = import ../development/libraries/libvpx {
+    inherit fetchurl stdenv bash;
+  };
+
   libvterm = import ../development/libraries/libvterm {
     inherit fetchurl stdenv pkgconfig ncurses glib;
   };
@@ -6069,13 +6101,47 @@ let
     inherit fetchurl stdenv ncurses;
   };
 
+  hurdCross = forceBuildDrv(import ../os-specific/gnu/hurd {
+    inherit fetchgit stdenv autoconf libtool texinfo machHeaders
+      mig glibcCross;
+    automake = automake111x;
+    headersOnly = false;
+    cross = assert crossSystem != null; crossSystem;
+    gccCross = gccCrossStageFinal;
+  });
+
+  hurdCrossIntermediate = forceBuildDrv(import ../os-specific/gnu/hurd {
+    inherit fetchgit stdenv autoconf libtool texinfo machHeaders
+      mig glibcCross;
+    automake = automake111x;
+    headersOnly = false;
+    cross = assert crossSystem != null; crossSystem;
+
+    # The "final" GCC needs glibc and the Hurd libraries (libpthread in
+    # particular) so we first need an intermediate Hurd built with the
+    # intermediate GCC.
+    gccCross = gccCrossStageStatic;
+
+    # This intermediate Hurd is only needed to build libpthread, which really
+    # only needs libihash.
+    buildTarget = "libihash";
+    installTarget = "libihash-install";
+  });
+
   hurdHeaders = import ../os-specific/gnu/hurd {
-    inherit fetchgit stdenv autoconf libtool texinfo machHeaders;
-    mig = migCross;
+    inherit fetchgit stdenv autoconf libtool texinfo mig machHeaders;
     automake = automake111x;
     headersOnly = true;
   };
 
+  hurdLibpthreadCross = forceBuildDrv(import ../os-specific/gnu/libpthread {
+    inherit fetchgit stdenv autoconf automake libtool
+      machHeaders hurdHeaders glibcCross;
+    hurd = hurdCrossIntermediate;
+    gccCross = gccCrossStageStatic;
+    cross = assert crossSystem != null; crossSystem;
+  });
+
   hwdata = import ../os-specific/linux/hwdata {
     inherit fetchurl stdenv;
   };
@@ -8123,7 +8189,7 @@ let
 
   MPlayer = import ../applications/video/MPlayer {
     inherit fetchurl stdenv freetype fontconfig x11 zlib libtheora libcaca libdvdnav
-      cdparanoia mesa pkgconfig unzip amrnb amrwb jackaudio x264 xvidcore;
+      cdparanoia mesa pkgconfig unzip amrnb amrwb jackaudio x264 xvidcore lame yasm;
     inherit (xlibs) libX11 libXv libXinerama libXrandr;
     alsaSupport = true;
     alsa = alsaLib;
@@ -8203,6 +8269,21 @@ let
     stdenv = stdenv2;
   };
 
+  go_oo = import ../applications/office/openoffice/go-oo.nix {
+    inherit fetchurl pam python tcsh libxslt perl zlib libjpeg
+      expat pkgconfig freetype fontconfig libwpd libxml2 db4 sablotron
+      curl libsndfile flex zip unzip libmspack getopt file cairo
+      which icu jdk ant cups openssl bison boost gperf cppunit;
+    inherit (xlibs) libXaw libXext libX11 libXtst libXi libXinerama;
+    inherit (gtkLibs) gtk;
+    inherit (perlPackages) ArchiveZip CompressZlib;
+    inherit (gnome) GConf ORBit2;
+    neon = neon026;
+    stdenv = stdenv2;
+
+    inherit autoconf openldap postgresql;
+  };
+
   opera = import ../applications/networking/browsers/opera {
     inherit fetchurl zlib glibc stdenv makeDesktopItem;
     inherit (xlibs) libX11 libSM libICE libXt libXext;
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 421684be43b5..7df0c8248612 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -1879,8 +1879,8 @@ rec {
       url = mirror://cpan/authors/id/G/GB/GBARR/libnet-1.22.tar.gz;
       sha256 = "113c36qilbvd69yhkm2i2ba20ajff7cdpgvlqx96j9bb1hfmhb1p";
     };
-    # Test perform network access
-    doCheck = false;
+    patchPhase = "chmod a-x Configure";
+    doCheck = false; # The test suite fails, because it requires network access.
   };
 
   NetSMTPSSL = buildPerlPackage {
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 48cdf1f143a9..5f9947ecd86a 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -685,11 +685,11 @@ rec {
   };
 
   twisted = buildPythonPackage {
-    name = "twisted-8.2.0";
+    name = "twisted-10.0.0";
 
     src = fetchurl {
-      url = http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-8.2.0.tar.bz2;
-      sha256 = "1c6zplisjdnjzkfs0ld3a0f7m7xbjgx5rcwsdw5i1xiibsq2nq70";
+      url = http://tmrc.mit.edu/mirror/twisted/Twisted/10.0/Twisted-10.0.0.tar.bz2;
+      sha256 = "1cbqpvwdwsc2av43fyqqdyyxs2j3drbagnl9m5vk7fl9k5q8q4fv";
     };
 
     propagatedBuildInputs = [ zopeInterface ];
diff --git a/pkgs/top-level/release-cross.nix b/pkgs/top-level/release-cross.nix
index 0845d73175cc..d4daf2652c35 100644
--- a/pkgs/top-level/release-cross.nix
+++ b/pkgs/top-level/release-cross.nix
@@ -6,6 +6,7 @@ let
   basicHostDrv = {
     bison.hostDrv = nativePlatforms;
     busybox.hostDrv = nativePlatforms;
+    coreutils_real.hostDrv = nativePlatforms;
     dropbear.hostDrv = nativePlatforms;
     tightvnc.hostDrv = nativePlatforms;
     #openoffice.hostDrv = nativePlatforms;
@@ -152,5 +153,14 @@ let
 in {
   crossGNU = mapTestOnCross crossSystem {
     gccCrossStageFinal = nativePlatforms;
+    hurdCross = nativePlatforms;
+
+    coreutils_real.hostDrv = nativePlatforms;
+    ed.hostDrv = nativePlatforms;
+    grub2.hostDrv = nativePlatforms;
+    inetutils.hostDrv = nativePlatforms;
+    nixUnstable.hostDrv = nativePlatforms;
+    patch.hostDrv = nativePlatforms;
+    zile.hostDrv = nativePlatforms;
   };
 })
diff --git a/pkgs/top-level/release-lib.nix b/pkgs/top-level/release-lib.nix
index 64530930ee50..be60de14ed81 100644
--- a/pkgs/top-level/release-lib.nix
+++ b/pkgs/top-level/release-lib.nix
@@ -3,7 +3,26 @@ rec {
 
   pkgs = allPackages {};
 
-  /* The working or failing letters for cross builds will be sent only to
+  /* !!! Hack: poor man's memoisation function.  Necessary for prevent
+     Nixpkgs from being evaluated again and again for every
+     job/platform pair. */
+  pkgsFor = system:
+    if system == "x86_64-linux" then pkgs_x86_64_linux
+    else if system == "i686-linux" then pkgs_i686_linux
+    else if system == "x86_64-darwin" then pkgs_x86_64_darwin
+    else if system == "i686-darwin" then pkgs_i686_darwin
+    else if system == "i686-freebsd" then pkgs_i686_freebsd
+    else if system == "i686-cygwin" then pkgs_i686_cygwin
+    else abort "unsupported system type: ${system}";
+
+  pkgs_x86_64_linux = allPackages { system = "x86_64-linux"; };
+  pkgs_i686_linux = allPackages { system = "i686-linux"; };
+  pkgs_x86_64_darwin = allPackages { system = "x86_64-darwin"; };
+  pkgs_i686_darwin = allPackages { system = "i686-darwin"; };
+  pkgs_i686_freebsd = allPackages { system = "i686-freebsd"; };
+  pkgs_i686_cygwin = allPackages { system = "i686-cygwin"; };
+
+  /* The working or failing mails for cross builds will be sent only to
      the following maintainers, as most package maintainers will not be
      interested in the result of cross building a package. */
   crossMaintainers = with pkgs.lib.maintainers; [ viric ];
@@ -23,7 +42,7 @@ rec {
      to build on that platform.  `f' is passed the Nixpkgs collection
      for the platform in question. */
   testOn = systems: f: {system ? builtins.currentSystem}:
-    if pkgs.lib.elem system systems then f (allPackages {inherit system;}) else {};
+    if pkgs.lib.elem system systems then f (pkgsFor system) else {};
 
   /* Similar to the testOn function, but with an additional 'crossSystem'
    * parameter for allPackages, defining the target platform for cross builds */
diff --git a/pkgs/top-level/release.nix b/pkgs/top-level/release.nix
index edb82944508f..47db7f587196 100644
--- a/pkgs/top-level/release.nix
+++ b/pkgs/top-level/release.nix
@@ -120,7 +120,7 @@ with (import ./release-lib.nix);
   gnum4 = all;
   gnumake = all;
   gnupatch = all;
-  gnupg2 = linux;
+  gnupg = linux;
   gnuplot = allBut "i686-cygwin";
   gnused = all;
   gnutar = all;