about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2020-03-15 18:43:45 +0000
committerGitHub <noreply@github.com>2020-03-15 18:43:45 +0000
commitf6e3f896c35e80dd8e0b087f38a2cb02d5357c38 (patch)
tree202ace97a1d569b0d857ee6213ba25365998c198 /pkgs/top-level
parentc82d1811203efd6d67feede08e163defd2689a66 (diff)
parent7f00b33261d65849027245115d19954ea3e67c5b (diff)
downloadnixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar.gz
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar.bz2
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar.lz
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar.xz
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.tar.zst
nixlib-f6e3f896c35e80dd8e0b087f38a2cb02d5357c38.zip
Merge pull request #82511 from alyssais/rust
rust_1_38, rust_1_42: drop patch version from attr
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/aliases.nix2
-rw-r--r--pkgs/top-level/all-packages.nix16
2 files changed, 10 insertions, 8 deletions
diff --git a/pkgs/top-level/aliases.nix b/pkgs/top-level/aliases.nix
index 3a504f20d944..19bf75f20a0d 100644
--- a/pkgs/top-level/aliases.nix
+++ b/pkgs/top-level/aliases.nix
@@ -385,6 +385,8 @@ mapAliases ({
   ruby_2_5_0 = throw "deprecated 2018-0213: use a newer version of ruby";
   rubyPackages_2_4 = throw "deprecated 2019-12: use a newer version of rubyPackages instead";
   rubygems = throw "deprecated 2016-03-02: rubygems is now bundled with ruby";
+  rust_1_38_0 = rust_1_38; # added 2020-03-13
+  rust_1_42_0 = rust_1_42; # added 2020-03-13
   rxvt_unicode-with-plugins = rxvt-unicode; # added 2020-02-02
   rxvt_unicode = rxvt-unicode-unwrapped; # added 2020-02-02
   urxvt_autocomplete_all_the_things = rxvt-unicode-plugins.autocomplete-all-the-things; # added 2020-02-02
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index a88870b66559..471016e6765d 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -8832,17 +8832,17 @@ in
     inherit (darwin) apple_sdk;
   };
 
-  rust_1_42_0 = callPackage ../development/compilers/rust/1_42_0.nix {
+  rust_1_42 = callPackage ../development/compilers/rust/1_42.nix {
     inherit (darwin.apple_sdk.frameworks) CoreFoundation Security;
   };
-  rust_1_38_0 = callPackage ../development/compilers/rust/1_38_0.nix {
+  rust_1_38 = callPackage ../development/compilers/rust/1_38.nix {
     inherit (darwin.apple_sdk.frameworks) CoreFoundation Security;
   };
-  rust = rust_1_42_0;
+  rust = rust_1_42;
 
-  rustPackages_1_42_0 = rust_1_42_0.packages.stable;
-  rustPackages_1_38_0 = rust_1_38_0.packages.stable;
-  rustPackages = rustPackages_1_42_0;
+  rustPackages_1_42 = rust_1_42.packages.stable;
+  rustPackages_1_38 = rust_1_38.packages.stable;
+  rustPackages = rustPackages_1_42;
 
   inherit (rustPackages) cargo clippy rustc rustPlatform;
   inherit (rust) makeRustPlatform;
@@ -8925,7 +8925,7 @@ in
     inherit (darwin.apple_sdk.frameworks) Security;
   };
   rustracerd = callPackage ../development/tools/rust/racerd {
-    inherit (rustPackages_1_38_0) rustPlatform;
+    inherit (rustPackages_1_38) rustPlatform;
     inherit (darwin.apple_sdk.frameworks) Security;
   };
   rust-bindgen = callPackage ../development/tools/rust/bindgen { };
@@ -21910,7 +21910,7 @@ in
 
   thunderbird = callPackage ../applications/networking/mailreaders/thunderbird {
     inherit (gnome2) libIDL;
-    inherit (rustPackages_1_38_0) cargo rustc;
+    inherit (rustPackages_1_38) cargo rustc;
     libpng = libpng_apng;
     gtk3Support = true;
   };