about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-05-20 14:25:09 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-05-20 14:25:09 +0000
commiteca684a44bbd356760881b8a9a65cc6c99212403 (patch)
tree500c0dea52c6d20c7c942fcde58e96bc80f5961b /pkgs/top-level
parentc21a987841b4c90413a4afa551ad19e2dda4f250 (diff)
downloadnixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar.gz
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar.bz2
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar.lz
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar.xz
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.tar.zst
nixlib-eca684a44bbd356760881b8a9a65cc6c99212403.zip
* Gnome 2.22.1.
* Moved some of the Gnome package Nix expressions into
  pkgs/desktops/gnome/default.nix - no need to have them in separate
  files.  This way the code is much shorter.  Still to be done for all
  the other Gnome packages.
* Glib 2.16.3.

svn path=/nixpkgs/branches/stdenv-updates/; revision=11855
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix37
1 files changed, 16 insertions, 21 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 693f4a8e3291..ae7ce1ed071f 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -576,8 +576,8 @@ rec {
   };
 
   gnupg2 = import ../tools/security/gnupg2 {
-	  inherit fetchurl stdenv readline openldap bzip2 zlib libgpgerror pth
-	    libgcrypt libassuan libksba libusb curl;
+    inherit fetchurl stdenv readline openldap bzip2 zlib libgpgerror pth
+      libgcrypt libassuan libksba libusb curl;
   };
 
   gnuplot = import ../tools/graphics/gnuplot {
@@ -2172,10 +2172,6 @@ rec {
       inherit stdenv fetchurl libtool gettext;
     });
 
-  audiofile = import ../development/libraries/audiofile {
-    inherit fetchurl stdenv;
-  };
-
   axis = import ../development/libraries/axis {
     inherit fetchurl stdenv;
   };
@@ -2417,12 +2413,12 @@ rec {
   };
 
   gnutls = import ../development/libraries/gnutls {
-	  inherit fetchurl stdenv libgcrypt zlib lzo;
+    inherit fetchurl stdenv libgcrypt zlib lzo;
   };
 
   gpgme = import ../development/libraries/gpgme {
     inherit fetchurl stdenv libgpgerror pkgconfig pth gnupg gnupg2;
-	inherit (gtkLibs) glib;
+    inherit (gtkLibs) glib;
   };
 
   # gnu scientific library
@@ -2767,6 +2763,10 @@ rec {
     inherit fetchurl stdenv;
   };
 
+  libtasn1 = import ../development/libraries/libtasn1 {
+    inherit fetchurl stdenv;
+  };
+
   libtheora = import ../development/libraries/libtheora {
     inherit fetchurl stdenv libogg libvorbis;
   };
@@ -4181,13 +4181,7 @@ rec {
     inherit (gtkLibs) glib gtk pango;
   };
 
-  librsvg = import ../development/libraries/librsvg {
-    inherit fetchurl stdenv;
-    inherit libxml2 pkgconfig cairo fontconfig freetype;
-    inherit (gtkLibs) glib pango gtk;
-    #gtkLibs = gtkLibs210;          #need gtk+
-    libart = gnome.libart_lgpl;
-  };
+  librsvg = gnome.librsvg;
 
   libsepol = import ../os-specific/linux/libsepol {
     inherit fetchurl stdenv;
@@ -5804,12 +5798,13 @@ rec {
 
 
   gnome = recurseIntoAttrs (import ../desktops/gnome {
-    inherit fetchurl stdenv pkgconfig audiofile
-            flex bison popt zlib libxml2 libxslt
-            perl perlXMLParser docbook_xml_dtd_42 docbook_xml_dtd_412
-            gettext x11 libtiff libjpeg libpng gtkLibs xlibs bzip2
-            libcm python dbus_glib ncurses which libxml2Python
-            iconnamingutils openssl hal samba fam;
+    inherit
+      fetchurl stdenv pkgconfig
+      flex bison popt zlib libxml2 libxslt
+      perl perlXMLParser docbook_xml_dtd_42 docbook_xml_dtd_412
+      gettext x11 libtiff libjpeg libpng gtkLibs xlibs bzip2
+      libcm python dbus_glib ncurses which libxml2Python
+      iconnamingutils openssl hal samba fam libgcrypt libtasn1;
   });
 
   kdelibs = import ../desktops/kde/kdelibs {