about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorOTABI Tomoya <tomoya.otabi@gmail.com>2024-01-07 17:07:02 +0900
committerGitHub <noreply@github.com>2024-01-07 17:07:02 +0900
commite38dfcf000e7a418ed06b448a06617e43ab524fa (patch)
treebe1ea267c8eb413da243ee65291d6d77bfb9ef2c /pkgs/top-level
parent98bb322ba9f5412e79d68e5bc34f7c7a69898897 (diff)
parentb30812af02827ef9958cc2a8cc05dfa490e57f79 (diff)
downloadnixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar.gz
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar.bz2
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar.lz
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar.xz
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.tar.zst
nixlib-e38dfcf000e7a418ed06b448a06617e43ab524fa.zip
Merge pull request #279257 from Stunkymonkey/ledger-agent-normalize
python311Packages.ledger-agent: rename from ledger_agent
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/aliases.nix1
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/python-aliases.nix1
-rw-r--r--pkgs/top-level/python-packages.nix2
4 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/top-level/aliases.nix b/pkgs/top-level/aliases.nix
index 10d4d1b2840b..38b26900f74e 100644
--- a/pkgs/top-level/aliases.nix
+++ b/pkgs/top-level/aliases.nix
@@ -484,6 +484,7 @@ mapAliases ({
   larynx = piper-tts; # Added 2023-05-09
   latinmodern-math = lmmath;
   ldgallery = throw "'ldgallery' has been removed from nixpkgs. Use the Flake provided by ldgallery instead"; # Added 2023-07-26
+  ledger_agent = ledger-agent; # Added 2024-01-07
   lfs = dysk; # Added 2023-07-03
   llvmPackages_rocm = throw "'llvmPackages_rocm' has been replaced with 'rocmPackages.llvm'"; # Added 2023-10-08
   libayatana-indicator-gtk3 = libayatana-indicator; # Added 2022-10-18
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 82aa738064d3..f62eb68356d9 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -37072,7 +37072,7 @@ with pkgs;
     inherit (darwin) autoSignDarwinBinariesHook;
   };
 
-  ledger_agent = with python3Packages; toPythonApplication ledger_agent;
+  ledger-agent = with python3Packages; toPythonApplication ledger-agent;
 
   ledger-live-desktop = callPackage ../applications/blockchains/ledger-live-desktop { };
 
diff --git a/pkgs/top-level/python-aliases.nix b/pkgs/top-level/python-aliases.nix
index 447348c23f16..93cc27da9bdd 100644
--- a/pkgs/top-level/python-aliases.nix
+++ b/pkgs/top-level/python-aliases.nix
@@ -239,6 +239,7 @@ mapAliases ({
   lazr_delegates = lazr-delegates; # added 2023-11-03
   lazy_import = lazy-import; # added 2024-01-07
   lazy_imports = lazy-imports; # added 2023-10-13
+  ledger_agent = ledger-agent; # Added 2024-01-07
   lektor = throw "lektor has been promoted to a top-level attribute"; # added 2023-08-01
   line_profiler = line-profiler; # added 2023-11-04
   livestreamer = throw "'livestreamer' has been removed, as it unmaintained. A currently maintained fork is 'streamlink'."; # added 2023-11-14
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 0f867cbf3124..636ab9178a97 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6242,7 +6242,7 @@ self: super: with self; {
     python3 = python;
   })).py;
 
-  ledger_agent = callPackage ../development/python-modules/ledger_agent { };
+  ledger-agent = callPackage ../development/python-modules/ledger-agent { };
 
   ledger-bitcoin = callPackage ../development/python-modules/ledger-bitcoin { };