about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-12-08 12:40:13 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-12-08 12:40:13 +0100
commite0950ae9ad7e101c16ce8bbc28d566c75bb298fb (patch)
treeb8a699d2b9218d8a9f6d29abe50d74999286b30e /pkgs/top-level
parent12e8ec041a28abd8c5cabd2c9e873df89e41b571 (diff)
parent85d9f63975cd76d78a026f257cd7205d6a1a8801 (diff)
downloadnixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar.gz
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar.bz2
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar.lz
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar.xz
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.tar.zst
nixlib-e0950ae9ad7e101c16ce8bbc28d566c75bb298fb.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/haskell-packages.nix11
-rw-r--r--pkgs/top-level/wine-packages.nix1
3 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 24074f922172..5cc844bd5dc1 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -7912,6 +7912,8 @@ in
   python37Packages = recurseIntoAttrs python37.pkgs;
   pypyPackages = pypy.pkgs;
 
+  update-python-libraries = callPackage ../development/interpreters/python/update-python-libraries { };
+
   # Should eventually be moved inside Python interpreters.
   python-setup-hook = callPackage ../development/interpreters/python/setup-hook.nix { };
 
diff --git a/pkgs/top-level/haskell-packages.nix b/pkgs/top-level/haskell-packages.nix
index 357ab21fba1f..af9ca77d9d21 100644
--- a/pkgs/top-level/haskell-packages.nix
+++ b/pkgs/top-level/haskell-packages.nix
@@ -68,6 +68,12 @@ in {
       buildLlvmPackages = buildPackages.llvmPackages_6;
       llvmPackages = pkgs.llvmPackages_6;
     };
+    ghc863 = callPackage ../development/compilers/ghc/8.6.3.nix {
+      bootPkgs = packages.ghc822;
+      inherit (buildPackages.python3Packages) sphinx;
+      buildLlvmPackages = buildPackages.llvmPackages_6;
+      llvmPackages = pkgs.llvmPackages_6;
+    };
     ghcHEAD = callPackage ../development/compilers/ghc/head.nix {
       bootPkgs = packages.ghc822Binary;
       inherit (buildPackages.python3Packages) sphinx;
@@ -130,6 +136,11 @@ in {
       ghc = bh.compiler.ghc862;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.6.x.nix { };
     };
+    ghc863 = callPackage ../development/haskell-modules {
+      buildHaskellPackages = bh.packages.ghc863;
+      ghc = bh.compiler.ghc863;
+      compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.6.x.nix { };
+    };
     ghcHEAD = callPackage ../development/haskell-modules {
       buildHaskellPackages = bh.packages.ghcHEAD;
       ghc = bh.compiler.ghcHEAD;
diff --git a/pkgs/top-level/wine-packages.nix b/pkgs/top-level/wine-packages.nix
index 8ff2d46c24e0..3a81a3d99bce 100644
--- a/pkgs/top-level/wine-packages.nix
+++ b/pkgs/top-level/wine-packages.nix
@@ -25,6 +25,7 @@ rec {
     udevSupport = true;
     xineramaSupport = true;
     xmlSupport = true;
+    sdlSupport = true;
   };
 
   full = base.override {