about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-08-04 13:30:24 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2018-08-04 13:30:24 +0200
commite002b543afd3bf770621423b91720fa50b8d5ec5 (patch)
treecc0d4ae67d513feacd2139bcd397a37e1590e66a /pkgs/top-level
parent455bf6d875b9c717d527559d04edadb0f0375b75 (diff)
downloadnixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar.gz
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar.bz2
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar.lz
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar.xz
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.tar.zst
nixlib-e002b543afd3bf770621423b91720fa50b8d5ec5.zip
python.pkgs.basiciw: move expression
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix22
1 files changed, 2 insertions, 20 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 2cc655542848..b0ae8a1e41aa 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -925,26 +925,8 @@ in {
 
   babelfish = callPackage ../development/python-modules/babelfish {};
 
-  basiciw = buildPythonPackage rec {
-    name = "${pname}-${version}";
-    version = "0.2.2";
-    pname = "basiciw";
-    disabled = isPy27 || isPyPy;
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/b/${pname}/${name}.tar.gz";
-      sha256 = "1ajmflvvlkflrcmqmkrx0zaira84z8kv4ssb2jprfwvjh8vfkysb";
-    };
-
-    buildInputs = [ pkgs.gcc ];
-    propagatedBuildInputs = [ pkgs.wirelesstools ];
-
-    meta = {
-      description = "Get info about wireless interfaces using libiw";
-      homepage = https://github.com/enkore/basiciw;
-      platforms = platforms.linux;
-      license = licenses.gpl2;
-    };
+  basiciw = callPackage ../development/python-modules/basiciw {
+    inherit (pkgs) gcc wirelesstools;
   };
 
   batinfo = callPackage ../development/python-modules/batinfo {};