about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorChris Martin <ch.martin@gmail.com>2016-05-10 20:37:32 -0400
committerChris Martin <ch.martin@gmail.com>2016-05-10 20:37:32 -0400
commitdb545f4b125d5166f7b2ea0d66c624c72e474fd9 (patch)
treec14925004c5ea0546c7af3cc1f596f6ace77e817 /pkgs/top-level
parent53643f532a5eeaa19ea9800683c3853b7255d862 (diff)
downloadnixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar.gz
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar.bz2
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar.lz
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar.xz
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.tar.zst
nixlib-db545f4b125d5166f7b2ea0d66c624c72e474fd9.zip
go-ethereum: init at 1.4.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/go-packages.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/top-level/go-packages.nix b/pkgs/top-level/go-packages.nix
index e040af2d3596..fca74bcdcc41 100644
--- a/pkgs/top-level/go-packages.nix
+++ b/pkgs/top-level/go-packages.nix
@@ -745,6 +745,22 @@ let
     sha256 = "1rmm1ky7irqypqjkk6qcd2n0xkzpaggdxql9dp9i9qci5rvvwwd4";
   };
 
+  ethereum = buildFromGitHub rec {
+    name = "ethereum";
+    rev = "v1.4.1";
+    goPackagePath = "github.com/ethereum/go-ethereum";
+    owner = "ethereum";
+    repo = "go-ethereum";
+    sha256 = "0z6yzkk72g41dzqa52fizxqxqh349y1m9s3byfh9ixq5xy5fnjn3";
+    preBuild = "export GOPATH=$GOPATH:$NIX_BUILD_TOP/go/src/${goPackagePath}/Godeps/_workspace";
+    postBuild = "rm $NIX_BUILD_TOP/go/bin/*test";
+    meta = with stdenv.lib; {
+      homepage = "https://ethereum.github.io/go-ethereum/";
+      description = "Official golang implementation of the Ethereum protocol";
+      license = with licenses; [ lgpl3 gpl3 ];
+    };
+  };
+
   exercism = buildFromGitHub {
     rev = "v2.2.1";
     name = "exercism";