about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2012-11-06 18:07:38 +0100
committerPeter Simons <simons@cryp.to>2012-11-06 18:34:54 +0100
commitce2e93a236bfb50a8faba375129e86ef70a5272f (patch)
treed541daa76ebb6565e05fc04d4f18aa6737ab64a1 /pkgs/top-level
parent7bb8c6ac8fdec4f2bae08b123ea0ef18ed3af42f (diff)
downloadnixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar.gz
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar.bz2
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar.lz
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar.xz
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.tar.zst
nixlib-ce2e93a236bfb50a8faba375129e86ef70a5272f.zip
Update default Haskell environment to Haskell Platform 2012.4.0.0.
The most significant change brought by this update is that we now use
GHC version 7.4.2 by default.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix15
-rw-r--r--pkgs/top-level/haskell-defaults.nix11
2 files changed, 8 insertions, 18 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 49f0918faff3..974eb3da9b6d 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -2319,9 +2319,9 @@ let
   # particularly in connection with Hydra builds for all these packages.
   # So we enable it for selected versions only.
 
-  # Current default version: 7.4.1.
-  haskellPackages = haskellPackages_ghc741;
-  # Current Haskell platform.
+  # Current default version: 7.4.2.
+  haskellPackages = haskellPackages_ghc742;
+  # Current Haskell Platform: 2012.4.0.0
   haskellPlatform = haskellPackages.haskellPlatform;
 
   haskellPackages_ghc6104             = recurseIntoAttrs (haskell.packages_ghc6104);
@@ -2338,11 +2338,10 @@ let
   # The following three lines achieve that: the first two make Hydra build explicit
   # profiling and non-profiling versions; the final respects the user-configured
   # default setting.
-  haskellPackages_ghc741_no_profiling = recurseIntoAttrs (haskell.packages_ghc741.noProfiling);
-  haskellPackages_ghc741_profiling    = recurseIntoAttrs (haskell.packages_ghc741.profiling);
-  haskellPackages_ghc741              = recurseIntoAttrs (haskell.packages_ghc741.highPrio);
-  haskellPackages_ghc742              = recurseIntoAttrs (haskell.packages_ghc742);
-  haskellPackages_ghc742_pedantic     =                   haskell.packages_ghc742_pedantic;
+  haskellPackages_ghc741              = recurseIntoAttrs (haskell.packages_ghc741);
+  haskellPackages_ghc742_no_profiling = recurseIntoAttrs (haskell.packages_ghc741.noProfiling);
+  haskellPackages_ghc742_profiling    = recurseIntoAttrs (haskell.packages_ghc741.profiling);
+  haskellPackages_ghc742              = recurseIntoAttrs (haskell.packages_ghc742.highPrio);
   haskellPackages_ghc761              = recurseIntoAttrs (haskell.packages_ghc761);
   # Reasonably current HEAD snapshot.
   haskellPackages_ghcHEAD             =                   haskell.packages_ghcHEAD;
diff --git a/pkgs/top-level/haskell-defaults.nix b/pkgs/top-level/haskell-defaults.nix
index b4489fe72e5a..aa43203fe533 100644
--- a/pkgs/top-level/haskell-defaults.nix
+++ b/pkgs/top-level/haskell-defaults.nix
@@ -22,18 +22,12 @@
       extensibleExceptions = self.extensibleExceptions_0_1_1_4;
     };
 
-  ghc742Prefs_pedantic =
+  ghc742Prefs =
     self : self.haskellPlatformArgs_2012_4_0_0 self // {
       haskellPlatform = self.haskellPlatform_2012_4_0_0;
       binary = null; # now a core package
     };
 
-  # until the Haskell Platform for 7.4.2 is released, this works fine/better;
-  # mainly because the Haskell Platform 2012.4.0.0 release candidate mandates
-  # vector 0.10 and primitive 0.5, which at this time aren't supported widely
-  # by other packages
-  ghc742Prefs = ghc741Prefs;
-
   ghc741Prefs =
     self : self.haskellPlatformArgs_2012_2_0_0 self // {
       haskellPlatform = self.haskellPlatform_2012_2_0_0;
@@ -273,9 +267,6 @@
                prefFun = ghc742Prefs;
              };
 
-  packages_ghc742_pedantic =
-    packages_ghc742.override { prefFun = ghc742Prefs_pedantic; };
-
   packages_ghc761 =
     packages { ghcPath = ../development/compilers/ghc/7.6.1.nix;
                ghcBinary = ghc704Binary;