about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-06 13:03:55 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-06 13:03:55 +0000
commitbb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c (patch)
treeaed666190f290fdd2488eae04fd31081880f6866 /pkgs/top-level
parent32588e53ef29c42a357db28bc924b1fa13f0cd3c (diff)
downloadnixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar.gz
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar.bz2
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar.lz
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar.xz
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.tar.zst
nixlib-bb2a310c5c4cbfacada0cdc685d4eb2dcda8f29c.zip
* Cleaned up the PHP expression. Added support for GD. Also
  turned on PostgreSQL support by default (maybe I shouldn't,
  since it makes PHP rather dependency-heavy...).

svn path=/nixpkgs/trunk/; revision=12002
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix25
1 files changed, 11 insertions, 14 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 205290882f12..4b7fdd5a6125 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -1831,30 +1831,27 @@ let pkgs = rec {
       if stdenv.isDarwin then null else unixODBC;
   };
 
-  # FIXME somehow somewhen: We need to recompile php if the ini file changes because the only way to
-  # tell the apache module where to look for this file is using a compile time flag ;-(
-  # perhaps this can be done setting php_value in apache don't have time to investigate any further ?
-  # This expression is a quick hack now. But perhaps it helps you adding the configuration flags you need?
-  php = php_unstable;
-
-  # compiling without xdebug is currenlty broken (should be easy to fix though 
-  php_unstable = (import ../development/interpreters/php_configurable) {
-    inherit stdenv mkDerivationByConfiguration autoconf automake lib;
-    # optional features
-    inherit fetchurl flex bison apacheHttpd mysql libxml2; # gettext;
-    inherit zlib curl;
-   flags = [ "xdebug" "mysql" "mysqli" "pdo_mysql" "libxml2" "apxs2" "curl" ];
+  php = import ../development/interpreters/php_configurable {
+    inherit
+      stdenv fetchurl lib mkDerivationByConfiguration autoconf automake
+      flex bison apacheHttpd mysql libxml2 # gettext
+      zlib curl gd postgresql;
+    flags = [
+      "xdebug" "mysql" "mysqli" "pdo_mysql" "libxml2" "apxs2" "curl"
+      "postgresql" "bcmath" "gd"
+    ];
   };
 
   python = python24;
 
   python24 = import ../development/interpreters/python/2.4 {
-  inherit fetchurl stdenv zlib bzip2;
+    inherit fetchurl stdenv zlib bzip2;
   };
 
   python25Fun = lib.sumArgs (import ../development/interpreters/python/2.5) {
     inherit fetchurl stdenv zlib bzip2 gdbm;
   };
+  
   python25 = python25Fun {
     db4 = if getConfig ["python" "db4Support"] false then db4 else null;
     sqlite = if getConfig ["python" "sqlite"] false then sqlite else null;