about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-03-11 15:36:26 +0100
committerMoritz U <moritz@tarn-vedra.de>2018-03-11 15:36:26 +0100
commitb14bd1803554a1750e8a96a393f48690337e1bb4 (patch)
treeb70988102e1ba0cc45155145842330902aa1cb19 /pkgs/top-level
parent4443c5f740a9f5eae9a85ab29f2f8fa08933ce3b (diff)
downloadnixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar.gz
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar.bz2
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar.lz
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar.xz
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.tar.zst
nixlib-b14bd1803554a1750e8a96a393f48690337e1bb4.zip
pythonPackages.mt-940: fix build (#36784)
- added missing `enum34` dependency
- enabled tests
- moved expression into its own file

See ticket #36453
See https://hydra.nixos.org/build/70677609/log

/cc @the-kenny
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix19
1 files changed, 1 insertions, 18 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index d0adbb054778..4529f7febd41 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -5446,24 +5446,7 @@ in {
     };
   };
 
-  mt-940 = buildPythonPackage rec {
-    version = "4.10.0";
-    name = "mt-940-${version}";
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/m/mt-940/mt-940-${version}.tar.gz";
-      sha256 = "1gyqf1k2r2ml45x08bk69ws865yrpcph514mn4xvjz779mlgh67j";
-    };
-
-    buildInputs = with self; [ pytestrunner pyyaml pytest ];
-    doCheck = false; # Can't find data files
-
-    meta = {
-      description = "A library to parse MT940 files and returns smart Python collections for statistics and manipulation";
-      homepage = "http://pythonhosted.org/mt-940/";
-      license = licenses.bsd3;
-    };
-  };
+  mt-940 = callPackage ../development/python-modules/mt-940 { };
 
   mwlib = let
     pyparsing = buildPythonPackage rec {