about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2021-02-11 15:43:09 +0900
committerPeter Simons <simons@cryp.to>2021-02-12 20:35:21 +0100
commitb0a16b29e2fe983433222afbc607f0573e8dceb2 (patch)
tree99402a02e4c3a0780a5fe1e0b022bcd00addc5c0 /pkgs/top-level
parentcb1e501568e5993e557b63fb3bdb6cc9b6faa62b (diff)
downloadnixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar.gz
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar.bz2
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar.lz
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar.xz
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.tar.zst
nixlib-b0a16b29e2fe983433222afbc607f0573e8dceb2.zip
haskell.compiler.ghc8104: add ghc-8.10.4
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/haskell-packages.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/top-level/haskell-packages.nix b/pkgs/top-level/haskell-packages.nix
index 46e222261fc8..6c8e3e7d855d 100644
--- a/pkgs/top-level/haskell-packages.nix
+++ b/pkgs/top-level/haskell-packages.nix
@@ -114,6 +114,16 @@ in {
       buildLlvmPackages = buildPackages.llvmPackages_9;
       llvmPackages = pkgs.llvmPackages_9;
     };
+    ghc8104 = callPackage ../development/compilers/ghc/8.10.4.nix {
+      # aarch64 ghc865Binary gets SEGVs due to haskell#15449 or similar
+      bootPkgs = if stdenv.isAarch64 || stdenv.isAarch32 then
+          packages.ghc8102BinaryMinimal
+        else
+          packages.ghc865Binary;
+      inherit (buildPackages.python3Packages) sphinx;
+      buildLlvmPackages = buildPackages.llvmPackages_9;
+      llvmPackages = pkgs.llvmPackages_9;
+    };
     ghc901 = callPackage ../development/compilers/ghc/9.0.1.nix {
       bootPkgs = packages.ghc8102Binary;
       inherit (buildPackages.python3Packages) sphinx;
@@ -221,6 +231,11 @@ in {
       ghc = bh.compiler.ghc8103;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.10.x.nix { };
     };
+    ghc8104 = callPackage ../development/haskell-modules {
+      buildHaskellPackages = bh.packages.ghc8104;
+      ghc = bh.compiler.ghc8104;
+      compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.10.x.nix { };
+    };
     ghc901 = callPackage ../development/haskell-modules {
       buildHaskellPackages = bh.packages.ghc901;
       ghc = bh.compiler.ghc901;