about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJohannes Bornhold <johannes@bornhold.name>2017-02-20 21:30:43 +0100
committerJohannes Bornhold <johannes@bornhold.name>2017-04-12 13:13:27 +0200
commitab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f (patch)
tree4b842a4c306b38b36d9ded6494073acfb69d9f55 /pkgs/top-level
parentb40cca244cfa37994533d1b5a9703a5de2edf2bd (diff)
downloadnixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar.gz
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar.bz2
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar.lz
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar.xz
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.tar.zst
nixlib-ab8bcd05f6fa970f7364a1fe3c51a74bdb5d225f.zip
pytestcov: 2.3.1 -> 2.4.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 9f65ef80b149..e6ba350d9229 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -5436,27 +5436,32 @@ in {
     '';
   };
 
-  pytestcov = buildPythonPackage (rec {
-    name = "pytest-cov-2.3.1";
+  pytestcov = buildPythonPackage rec {
+    name = "pytest-cov-2.4.0";
 
     src = pkgs.fetchurl {
       url = "mirror://pypi/p/pytest-cov/${name}.tar.gz";
-      sha256 = "fa0a212283cdf52e2eecc24dd6459bb7687cc29adb60cb84258fab73be8dda0f";
+      sha256 = "03c2qc42r4bczyw93gd7n0qi1h1jfhw7fnbhi33c3vp1hs81gm2k";
     };
 
-   buildInputs = with self; [ covCore pytest virtualenv process-tests helper ];
+   buildInputs = with self; [ pytest pytest_xdist virtualenv process-tests ];
+   propagatedBuildInputs = with self; [ coverage ];
 
+   # xdist related tests fail with the following error
+   # OSError: [Errno 13] Permission denied: 'py/_code'
    doCheck = false;
    checkPhase = ''
+     # allow to find the module helper during the test run
+     export PYTHONPATH=$PYTHONPATH:$PWD/tests
      py.test tests
    '';
 
     meta = {
       description = "Plugin for coverage reporting with support for both centralised and distributed testing, including subprocesses and multiprocessing";
-      homepage = https://github.com/schlamar/pytest-cov;
+      homepage = https://github.com/pytest-dev/pytest-cov;
       license = licenses.mit;
     };
-  });
+  };
 
   pytest-expect = callPackage ../development/python-modules/pytest-expect { };